CentOS7提示 libsasl2.so.2 cannot open shared object file
发表于|更新于|CentOS
|总字数:98|阅读时长:1分钟|浏览量:
背景
最近服务器升级了CentOS7.9,在重新部署服务后,运行模型训练,提示了如下错误:
1 | libsasl2.so.2: cannot open shared object file: No such file or directory |
解决办法
将系统自带的libsasl2.so.3.0.0 软链到 libsasl2.so.2
1 | ln -s /usr/lib64/libsasl2.so.3.0.0 /usr/lib64/libsasl2.so.2 |
再次执行python程序就不会出现这个错误了。
文章作者: Charles
版权声明: 本博客所有文章除特别声明外,均采用 CC BY-NC-SA 4.0 许可协议。转载请注明来源 码农笔记!
相关推荐

2021-08-09
pip安装依赖提示mysql_config command not found
在CentOS7使用pip安装Python依赖时,遇到了错误提示:mysql_config command not found,再次记录下解决方法。 错误再现1bin/pip3 install -r requirements.txt 安装依赖时,提示了如下错误: 123456789101112131415161718192021 Downloading https://files.pythonhosted.org/packages/3c/df/59cd2fa5e48d0804d213bdcb1acb4d08c403b61c7ff7ed4dd4a6a2deb3f7/mysqlclient-2.0.3.tar.gz (88kB) 100% |████████████████████████████████| 92kB 613kB/s Complete output from command python setup.py egg_info: /bin/sh: mysql_config: command not found /bin/sh: maria...

2019-07-19
在CentOS中安装redis5.0
前不久,Redis官方便放出了Redis5.0RC版,新增了不少新特性,想尝尝鲜,于是就在618新买的京东云主机(4C8G)中进行安装。 环境介绍 CentOS7 (未安装Development Tools) 4C8G(其实1c1g足够玩了,谁让京东打折这么猛呢。。) 下载Redis5.0-rc31wget -O redis-5.0-rc3.tar.gz https://github.com/antirez/redis/archive/5.0-rc3.tar.gz 解压redis1tar -zxvf redis-5.0-rc3.tar.gz -C /usr/local 编译并安装12cd /usr/local/redis-5.0-rc3make 此时会出错: 1234compilation terminated.make[1]: *** [adlist.o] Error 1make[1]: Leaving directory `/usr/local/redis-5.0-rc3/src'make: *** [all] Error 2 安装Development Too...

2023-03-21
Java和Python通过gRPC互相调用
基于前两篇,本篇介绍下如果用Java和Python通过gRPC互相调用 安装依赖123pip install grpciopip install grpcbufpip install grpcio-tools 准备.proto文件注意,该文件需要与Java项目中的.proto保持一致 1234567891011121314151617syntax = "proto3";package example;// The greeting service definition.service Greeter { // Sends a greeting rpc SayHello (HelloRequest) returns (HelloReply) {}}// The request message containing the user's name.message HelloRequest { string name = 1;}// The response messa...

2022-07-04
CentOS7离线升级GCC
CentOS默认安装的GCC版本都是4.8.5,但是编译安装Redis时会提示GCC版本太低,所以我们需要升级到最新版本,本次是将GCC升级到gcc-9.5.0。 安装GCC升级GCC前,先需要安装默认的GCC。 1yum install -y gcc-c++ 升级GCC下载GCC安装包及依赖包下载地址:Index of /gnu/gcc/gcc-9.5.0 解压gcc-9.5.0 12tar -xf gcc-9.5.0.tar.gz -C /usr/local/cd /usr/local/gcc-9.5.0 打开gcc -> gcc-9.5.0/contrib/download_prerequisites,找到依赖包的名字: 1234gmp-6.1.0.tar.bz2 ...

2019-08-14
卸载Oracle
操作Oracle的时候失误导致Oracle无法启动了,试过了所有的办法依旧不行,主要体现在无法登录sysdba,那么此时什么操作都做不了,无奈之下只能选择重装了,不过在重装Oracle前就需要先卸载已安装的Oracle。 关闭Oracle数据库12345sqlplus /nologconn / as sysdbaSHUTDOWN IMMEDIATE; 停止Listerner进程1lsnrctl stop 使用deinstlal删除Oracle的可执行文件和配置文件由于操作失误,无法登录sysdba,只能从第三步开始了。在$ORACLE_HOME/deinstall/下,执行: 1./deinstall 此时会输出如下信息: 123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687...

2023-06-25
Linux保持长时间会话不断开
使用SSH方式登录Linux操作系统的云服务器时,过一段时间就会自动断开连接。本篇操作介绍如何保持SSH会话持续连接不断开。 配置sshd可通过修改sshd配置文件来解决自动断开的问题,编辑/etc/ssh/sshd_config文件设置心跳,保持连接。 1234vim /etc/ssh/sshd_config# 新增如下两个配置ClientAliveInterval 600 ClientAliveCountMax 10 ClientAliveInterval 600 表示每600秒发送一次请求, 从而保持连接。 ClientAliveCountMax 10 表示服务器发出请求后客户端没有响应的次数达到10次,就自动断开连接。 无响应的SSH客户端将在大约600x10=6000秒后断开连接。 ClientAliveInterval设置超时间隔(以秒为单位),在此间隔之后,如果尚未从客户端接收到任何数据,则sshd将通过加密的通道发送消息以请求客户端的响应。默认值为0,表示这些消息将不会发送到客户端。此选项仅适用于协议版本2。Clien...
评论
公告
开始忙了,长草期。






